NetBSD×Core2Duo ThinkPad X60


 NetBSD歴25日目です。
 新しく買ったCore2Duo ThinkPad X60からWindows Vistaを消し去ってNetBSD 3.1を導入し、環境設定を行いました。
 以下NetBSD 3.1をThinkPad X60で使用するための設定メモ。
 結局NetBSD 3.1ではなく、カーネルの更新やユーザーランドの更新とかやったら
カーネルとユーザーランドが4.0_Beta2、pkgsrcがcurrentの環境で落ち着きました。
■X60内蔵SATAディスクが見えなくてNetBSD 3.1が導入できない。
 BIOSでSATAが「AHCI」に設定されていると導入できないので、「互換」にしなければならない。
 原因はNetBSD 3.1側で未対応なためで、AHCI SATAが認識出来ないというもの。
  NetBSD 3.1-currentにコミットしたという情報 があるので、3.1の場合はcurrentにして再構築すれば回避できるかもしれない。
 4.0_Beta2ではAHCIのままで稼働する。

$ dmesg | grep ahci
ahcisata0 at pci0 dev 31 function 2: Intel 82801GBM AHCI SATA Controller
ahcisata0: AHCI revision 1.1, 4 ports, 32 command slots, features 0xc710e000
ahcisata0: interrupting at ioapic0 pin 16 (irq 11)
atabus1 at ahcisata0 channel 0
ahcisata0 port 0: device present, speed: 1.5Gb/s
wd0(ahcisata0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 5 (Ultra/100) (using DMA)

■時刻が9時間ずれる
 カスタムカーネルを作成して起動する。

# cd /usr/src/sys/arch/i386/conf
# cp -p GENERIC GENERIC.bk
# vi GENERIC

 以下を修正する。

options RTC_OFFSET=-540 # hardware clock is this many mins. west of GMT

 カーネルの再構築をする。3.1も4.0も同様。
 5分くらいで終わる。
 ※GENERIC.MPは中でSMP以外の設定のGENERICをincludeしているので、SMPの場合はGENERIC.MPを使う。

# cp -p GENERIC.MP MY-ZHiME.Zwei
# config MY-ZHiME.Zwei
# cd ../compile/
# make depend && make && make install
# reboot

 再起動後確認。

$ uname -a
NetBSD mhutps12.hmxdc01.local 4.0_BETA2 NetBSD 4.0_BETA2 (MY-ZHiME.Zwei) #0: Sun Mar 25 13:54:51 JST 2007 root@mhutps12.hmxdc01.local:/usr/src/sys/arch/i386/compile/MY-ZHiME.Zwei i386
■NetBSD 3.1カスタムカーネル

■NetBSD 4.0_Beta2カスタムカーネル

■X60オンボードIntel i82573L Gigabit Ethernetがwm0で認識しない。
 NetBSD 3.1では対応していないのが原因。再構築してもダメだった。
  Release 4.99.3で対応された ようなので、3.1系では使えないかも。
 4.0_Beta2に更新して再構築したら認識して使えるようになった。

$ dmesg | grep wm0
wm0 at pci1 dev 0 function 0: Intel i82573L Gigabit Ethernet, rev. 0
wm0: interrupting at ioapic0 pin 16 (irq 11)
wm0: PCI-Express bus
wm0: 256 word (8 address bits) SPI EEPROM
wm0: Ethernet address 00:00:00:00:00:00
makphy0 at wm0 phy 1: Marvell 88E1111 Gigabit PHY, rev. 2

■X60無線LANが認識しない
 3.1から4.0_Beta2に更新したら認識はした。
 動作は未確認。

$ dmesg | grep ath0
ath0 at pci2 dev 0 function 0
ath0: interrupting at ioapic0 pin 17 (irq 11)
ath0: 11a rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: mac 10.3 phy 6.1 radio 10.2

 そのほかXF86からxorgへの移行、kdeに関しては後日。
 とりあえず自作スプラッシュはエアリーズのデルタオトメ部隊ということでw

電脳ぺんぎん の紹介

HMX.NET の中の人。株式会社ノー・コントラクト勤務。ディズニー好きで2パーク年パス所持者。暇があればTDSかTDRのどちらかにいます。趣味は化石・鉱物収集。かつて夕張、山ノ尾、妙見山、錫高野に入り浸っていました。
カテゴリー: BSD, ThinkPad, X60 パーマリンク

コメントは停止中です。